MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000219SoldatGameplaypublic2012-05-26 23:592016-04-19 21:51
ReporterTheOne 
Assigned To 
PriorityhighSeveritymajorReproducibilityrandom
StatusconfirmedResolutionreopened 
Platformx86OSWindowsOS VersionXP SP3
Product Version1.6.3 
Target VersionFixed in Version1.6.4 
Summary0000219: Soldat forcing you to leave game
DescriptionJust like the other bug I posted, happens randomly and since 1.6.2 or 1.6.3.
What happens is following: F1 menu pops up, the text ".. has left .. team" appears in the console. However nothing happens, the game stays in this status until you leave it manually. For other players it just appears that you leave the game. For me, everything froze, but that might be a result of script pausing the game when someone leaves.
TagsNo tags attached.
Attached Files

- Relationships
related to 0000085closedFryer Rejoin bug 
related to 0000218closedShoozza Soldat forcing you to rejoin 
related to 0000200confirmed Packetloss of important informations 

-  Notes
(0001557)
Shoozza (administrator)
2012-06-23 15:13

Note: Something similar happens when the server goes offline or you lose connection to the internet just with a red message "connection lost to the server" (something close to that) but that is normal.

Your bugreport sounds different. I assume either your internet connection isn't that great and you get corrupted packets or the server sends bad packets.
It may be that you get a leaving game packet which causes this.

Anyways, please make a demo so we can have a look.
(0001593)
TheOne (reporter)
2012-09-12 18:49

I tried to record a demo (auto-recorded as it happens randomly). However when rewatching it stopped playing the demo with an error message at that point.
Making a demo as spectator of that bug is useless as you just see the person leaving the game.
It happens maybe once in five gathers and I've had it on other servers as well. I'm not sure how it is related to the Rejoin bug.. there I just exited my team and the Join-Team menu popped up. Others would just see "The One has joined bravo team" once again.

One information that might be helpful to you: Right before the player leaves the game due to that bug he always requests game.
ARSSE Log:
# (17:41:26) *.*.*.*:23073 requesting game...
# (17:41:26) [WP] +The One has left bravo team.
The IP being the one of the player who left
(0001594)
TheOne (reporter)
2012-09-12 19:32

Also: It's not just me. Others have it as often as myself.
(0001623)
TheOne (reporter)
2012-11-12 10:46

Another update: One time we played on a map where this bug occured much more frequently than usual. When the map was changed, it didn't repeat itself.
So.. it *might* be connected to the map, maybe caused by the auto-map-download as it was suspected? Since it only happens in the new versions.
(0001730)
Falcon (administrator)
2013-06-25 13:57

Marking as resolved, as duplicate seems to be.
(0001785)
TheOne (reporter)
2013-07-25 22:51

This is not a duplicate of the rejoin bug, and it still occurs in 1.6.4.
(0001929)
TheOne (reporter)
2013-09-15 13:56

Still occurs in 1.6.5 quite frequently.
(0002061)
homerofgods (updater)
2013-12-08 11:51

Still in 1.6.6?
Hmm upload a demo even if it gives error.

In your report you say: F1 menu pops up, the text ".. has left .. team" appears in the console.

But in comment you say: there I just exited my team and the Join-Team menu popped up. Others would just see "The One has joined bravo team" once again.

The second sounds like the rejoin bug..
(0002090)
TheOne (reporter)
2013-12-15 16:45

It still happens in 1.6.6, yes.
I will try to get the demo.
Yes, in that comment I was talking about the rejoin bug, which has been fixed by now (at least didn't happen again to me). I was comparing it to this leave bug, so.. just ignore it :)
(0002518)
TheOne (reporter)
2015-11-16 19:13
edited on: 2015-11-17 09:22

Still happens in 1.6.9. Can't get a demo because it's so random and I can't record it after it happens, as i left the game by then

It just appears as a normal leave, I get back to the lobby and players see me as leaving, while I didn't tell my client to leave the game

(0002526)
Falcon (administrator)
2015-12-31 16:16

As far as i can tell, this happens in the case when you have wrong map version, and server has a script to pause the game when somebody leaves. Your clients make you leave the game to redownload the map, but gets stuck because of game pause at that very moment. You then leave yourself, but it's no longer recognized as "Wrong map version leave" and when you join, you do NOT redownload the map.
(0002543)
TheOne (reporter)
2016-03-29 23:30

but this happens mid-game after playing on that map since several minutes. I don't think it can be related to WMV.
Still happens in 1.7.0

- Issue History
Date Modified Username Field Change
2012-05-26 23:59 TheOne New Issue
2012-06-23 15:13 Shoozza Note Added: 0001557
2012-06-23 15:13 Shoozza Assigned To => Shoozza
2012-06-23 15:13 Shoozza Status new => feedback
2012-06-23 15:13 Shoozza Assigned To Shoozza =>
2012-06-23 15:14 Shoozza Relationship added related to 0000085
2012-09-12 18:49 TheOne Note Added: 0001593
2012-09-12 18:49 TheOne Status feedback => new
2012-09-12 19:32 TheOne Note Added: 0001594
2012-11-12 10:46 TheOne Note Added: 0001623
2013-06-25 13:57 Falcon Note Added: 0001730
2013-06-25 13:57 Falcon Relationship replaced duplicate of 0000085
2013-06-25 13:57 Falcon Status new => resolved
2013-06-25 13:57 Falcon Fixed in Version => 1.6.4
2013-06-25 13:57 Falcon Resolution open => fixed
2013-06-25 13:57 Falcon Assigned To => Fryer
2013-07-25 22:51 TheOne Note Added: 0001785
2013-07-25 22:51 TheOne Status resolved => feedback
2013-07-25 22:51 TheOne Resolution fixed => reopened
2013-09-15 13:56 TheOne Note Added: 0001929
2013-09-15 13:56 TheOne Status feedback => assigned
2013-12-08 11:51 homerofgods Note Added: 0002061
2013-12-15 16:45 TheOne Note Added: 0002090
2014-11-17 19:56 Shoozza Assigned To Fryer =>
2014-11-17 19:58 Shoozza Status assigned => feedback
2015-04-15 15:20 homerofgods Relationship added duplicate of 0000218
2015-04-15 15:25 homerofgods Relationship deleted 0000085
2015-04-15 15:25 homerofgods Relationship added related to 0000085
2015-04-15 15:25 homerofgods Relationship deleted 0000218
2015-04-15 15:25 homerofgods Relationship added related to 0000218
2015-04-15 19:05 homerofgods Relationship added related to 0000200
2015-11-16 19:13 TheOne Note Added: 0002518
2015-11-16 19:13 TheOne Status feedback => new
2015-11-17 09:22 TheOne Note Edited: 0002518 View Revisions
2015-12-31 16:16 Falcon Note Added: 0002526
2015-12-31 16:16 Falcon Assigned To => Falcon
2015-12-31 16:16 Falcon Status new => confirmed
2016-03-29 23:30 TheOne Note Added: 0002543
2016-04-19 21:51 Falcon Assigned To Falcon =>


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker