MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000104SoldatGUIpublic2011-10-13 12:572013-12-30 00:15
Reporterxeno 
Assigned ToShoozza 
PrioritynormalSeveritytextReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.6.2 
Target VersionFixed in Version1.6.3 
Summary0000104: Missing translations and small labels in Soldat.exe
DescriptionRegarding Shoozza's note in the last similar bug-report (http://bugs.soldat.pl/view.php?id=4#c1223 [^]), I'm now making two different reports - one for 'Soldat.exe' and one for 'Config.exe'.

This is the one for 'Soldat.exe'.

"Enable background color Override" - 'Player' tab, tooltip for the background color forcing check-box/label; was added to the translation file with Soldat version 1.6.2 yet doesn't seem to be used

"Adds extra features regarding Voice Chat if you have TeamSpeak2 running in the background" - 'Settings' tab, tooltip for 'TeamSpeak' checkbox

The "Map" string in client's dedicated mode uses line from 258 ("Map") which is used with the line 259 "not found or can't be downloaded" and due to linguistic reasons is more likely to differ in other languages, I'd suggest using line 351 ("Map") which is used in the lobby above the list of servers and is most likely in the form suitable for usage on the label in question as well.

Short/not dynamic label -
The one preceding the spectator checkbox under Join game tab ("Spectator")
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001226)
xeno (reporter)
2011-10-13 13:05

Forgot to also note the following missing translations:

All the colors in the various color selection boxes at the 'Player' tab.

All the game types under filter settings at the 'Join game' tab (could use the already translated game type translations)
(0001261)
Shoozza (administrator)
2011-12-15 09:24

Fixed all issues except missing translations in:
All the colors in the various color selection boxes at the 'Player' tab.

The library we use for that depends on English names (e.g. the Custom value for showing the color picker)

This will eventually be fixed when we replace the GUI when moving to Lazarus/FreePascal as our main IDE/Compiler.

- Issue History
Date Modified Username Field Change
2011-10-13 12:57 xeno New Issue
2011-10-13 13:05 xeno Note Added: 0001226
2011-12-15 09:24 Shoozza Note Added: 0001261
2011-12-15 09:24 Shoozza Status new => resolved
2011-12-15 09:24 Shoozza Fixed in Version => 1.6.3
2011-12-15 09:24 Shoozza Resolution open => fixed
2011-12-15 09:24 Shoozza Assigned To => Shoozza
2013-12-30 00:15 homerofgods Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker