MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000017SoldatGUIpublic2011-09-14 13:152012-06-23 15:17
ReporterQuantifier 
Assigned To 
PriorityhighSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformPCOSWindows XPOS VersionSP2
Product Version1.6.0 
Target VersionFixed in Version1.6.3 
Summary0000017: Access violation with caused by fonts.
DescriptionWhen FontConsoleSize is set to 9 in txt\font.ini, game becomes unplayable. Whenever F1 scoreboard or F2 statisticts appears, or player opens input for chat or a command, game throws continuous flood of access violation errors.
With font size 10, no error happens.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001132)
Shoozza (administrator)
2011-09-17 21:39

Doesn't happen for me.

My font.ini:
[FONTS]
Font1=BankGothic Lt BT
Font2=Lucida Console
FontMenuSize=12
FontConsoleSize=9
FontBigSize=28
FontWeaponMenuSize=8
FontConsoleSmallSize=7
FontHeightScale=125
FontMenuBold=1
FontConsoleBold=0
FontBigBold=1
FontWeaponMenuBold=0
FontConsoleSmallBold=0
KillConsoleNameSpace=8

What do the error messages you get look like? Exact message text would be really helpful.
(0001138)
Quantifier (reporter)
2011-09-18 19:48

Your font.ini is the same as mine except for the lines "FontHeightScale=100" (which doesn't affect bug, whether 125 or 100), and "FontConsoleSize=10" (which I had to change in order to run the game)

The message looks like standard Windows error message, with text "Access violation at address 006115DB in module 'Soldat.exe' Read of address 00000000."
(0001158)
Shoozza (administrator)
2011-09-22 04:52

Found out why this is happening.
It seems like your graphics card cannot create font textures for the font size.
I changed it to stop drawing to the texture and log the error (when logging=1 is set in soldat.ini).

The game should run but there will be text missing.
Once the next version is out please run soldat with logging enabled, reopen the bugreport and add the log file (log.txt in logs folder).
(0001159)
Shoozza (administrator)
2011-09-22 04:53

Found out why this is happening.
It seems like your graphics card cannot create font textures for the font size.
I changed it to stop drawing to the texture and log the error (when logging=1 is set in soldat.ini).

The game should run but there will be text missing.
Once the next version is out please run soldat with logging enabled, reopen the bugreport and add the log file (log.txt in logs folder).
(0001558)
Shoozza (administrator)
2012-06-23 15:17

closed if you still have issues open a new bug report

- Issue History
Date Modified Username Field Change
2011-09-14 13:15 Quantifier New Issue
2011-09-17 21:39 Shoozza Note Added: 0001132
2011-09-17 21:39 Shoozza Assigned To => Shoozza
2011-09-17 21:39 Shoozza Status new => feedback
2011-09-18 19:48 Quantifier Note Added: 0001138
2011-09-18 19:48 Quantifier Status feedback => assigned
2011-09-21 02:10 Shoozza Status assigned => confirmed
2011-09-22 04:52 Shoozza Note Added: 0001158
2011-09-22 04:52 Shoozza Status confirmed => resolved
2011-09-22 04:52 Shoozza Fixed in Version => 1.6.1
2011-09-22 04:53 Shoozza Note Added: 0001159
2012-06-23 15:17 Shoozza Resolution open => fixed
2012-06-23 15:17 Shoozza Note Added: 0001558
2012-06-23 15:17 Shoozza Status resolved => closed
2012-06-23 15:17 Shoozza Assigned To Shoozza =>
2012-06-23 15:17 Shoozza Fixed in Version 1.6.1 => 1.6.3


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker