MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000170SoldatGameplaypublic2012-03-04 22:162014-02-03 23:33
ReporterExHunter 
Assigned Toskoskav 
PriorityimmediateSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Platformx64OSWindowsOS VersionVista SP2
Product Version1.6.2 
Target VersionFixed in Version1.6.7 
Summary0000170: Moving speed while jumping
DescriptionWell,

If you run from right to left and you are facing to the left and you jump, your speed will be higher, than facing to the right. I think that works as intended, because it makes sense.

But now: If you run from left to right and you are facing to the right and you jump, your speed will be the same, whether you are looking to the left side or right side. Also it is slower than the first "faster" scenario. See attachment.
Steps To ReproduceI think, that I already explained it well enough.
Additional InformationFor the speed counter I used the !RunMode Server, to check my movement speed. I would also like that "feature" (if its intended or not), implement for both sides instead of removing it, because it gives Soldat a bit more realistic physics.
TagsNo tags attached.
Attached Filesjpg file icon lefttorightrighttoleftrun.jpg [^] (32,958 bytes) 2012-03-04 22:16


gif file icon InverseCannonBall.gif [^] (1,167,298 bytes) 2013-12-03 07:36
gif file icon InverseProneCancel.gif [^] (1,190,526 bytes) 2013-12-03 07:36

- Relationships

-  Notes
(0001388)
Bistoufly (updater)
2012-03-06 05:30

A little correction:

The part about jumping to the left is correct.

but,

When jumping to the right side: It's faster to jump facing backwards than it is to jump facing forwards.

So the change that is needed here is to make facing forward, the fastest way in both jumping directions (left AND right).

According to my tests in the runmode server. The speed diference is about 5%.

other usefull info:
.It affect jumps ( and any advanced moves beginning with a jump
( cannon balls, surfing, ... )

.It doesn't affect walking.
(0001403)
ginn (reporter)
2012-03-27 01:03

It does also affect acceleration and speed while gliding on Ice... which I noticed while making a map.
(0002028)
Bistoufly (updater)
2013-12-03 07:33
edited on: 2013-12-03 07:37

From this week's devlog: "* Fixed movement speed was slightly lower when facing right 0000170" see: http://forums.soldat.pl/index.php?topic=43151.msg516656#msg516656 [^]

This is not the fix that was needed. By removing the slight difference between facing forward and backward, You effectively render useless several movement tricks such as the:
- Inverse Cannon Ball. see: InverseCannonBall.gif
- Inverse Prone Cancel. see: InverseProneCancel.gif

Could you please instead implement it for both jumping direction as it was suggested in the ticket and in my comment?

Relevant quotes:
- "I would also like that "feature" (if its intended or not), implement for both sides instead of removing it, because it gives Soldat a bit more realistic physics." -ExHunter

- "So the change that is needed here is to make facing forward, the fastest way in both jumping directions (left AND right)." -Bistoufly

(0002042)
skoskav (developer)
2013-12-04 01:06

Why are these two moves now useless? Did they only work when performing them in one direction? What happens when you try to do them in the other direction?
(0002048)
Bistoufly (updater)
2013-12-04 08:29

"Did they only work when performing them in one direction?"
  Runners use inverse cb/pc when going to the left.
  Normal cb/pc is used when going to the right.

"What happens when you try to do them in the other direction?"
  On a straight route, if you inverse cb/pc when going to the right, you will lose time. (Compared to using normal cb/pc.)

"Why are these two moves now useless?"
  If the way you face has no impact on jumping, then there is no use in tweaking your cb/pc to face a certain way. It's a shame, because it's extremely fun and satisfactory to perform these. And yet the difference is tiny enough that it doesn't create any imbalance between the player that use this trick vs the ones that don't use it.

=> How would we like to see this work ideally:

- when going left: same behavior as current version. (when jumping left on a straight route, facing forward(left)allows you to build slightly more momentum than facing backward (right))

- when going right: mirror the behavior of going left. (when jumping right on a straight route, facing forward(right)would allow you to build slightly more momentum than facing backward (left))
(0002130)
skoskav (developer)
2014-02-03 23:33

Changed so you're moving the fastest when also facing that direction (and vice versa).

Though technically speaking this doesn't directly have to do with movement speed. It's really the repelling force of the collision checking which was biased to one facing direction. I just made it also factor in the left/right movement now.

- Issue History
Date Modified Username Field Change
2012-03-04 22:16 ExHunter New Issue
2012-03-04 22:16 ExHunter File Added: lefttorightrighttoleftrun.jpg
2012-03-06 05:30 Bistoufly Note Added: 0001388
2012-03-27 01:03 ginn Note Added: 0001403
2013-11-26 03:36 skoskav Status new => resolved
2013-11-26 03:36 skoskav Fixed in Version => 1.6.7
2013-11-26 03:36 skoskav Resolution open => fixed
2013-11-26 03:36 skoskav Assigned To => skoskav
2013-12-03 07:33 Bistoufly Note Added: 0002028
2013-12-03 07:33 Bistoufly Status resolved => feedback
2013-12-03 07:33 Bistoufly Resolution fixed => reopened
2013-12-03 07:36 Bistoufly File Added: InverseCannonBall.gif
2013-12-03 07:36 Bistoufly File Added: InverseProneCancel.gif
2013-12-03 07:37 Bistoufly Note Edited: 0002028 View Revisions
2013-12-04 01:06 skoskav Note Added: 0002042
2013-12-04 08:29 Bistoufly Note Added: 0002048
2013-12-05 06:44 Bistoufly Priority high => urgent
2013-12-08 22:02 Bistoufly Priority urgent => immediate
2014-02-03 23:33 skoskav Note Added: 0002130
2014-02-03 23:33 skoskav Status feedback => resolved
2014-02-03 23:33 skoskav Resolution reopened => fixed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker