MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000284SoldatOtherpublic2012-12-25 16:322014-01-27 19:03
ReporterMcWise 
Assigned Toskoskav 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformx64OSWindowsOS Version7
Product Version1.6.3 
Target VersionFixed in Version1.6.4 
Summary0000284: Killing someone with knife and switching to Barret or Ruger before the kill invokes "boom headshot yeah" sound.
DescriptionKilling someone with knife and switching to Barret or Ruger before the kill invokes "boom headshot yeah" sound.
Steps To ReproduceHave a friend play with you. Equip knife and Ruger or Barret. Make a throw-knife headshot to your friend and switch to your primary weapon BEFORE the knife reaches him. It will play the "boom headshot yeah" sound.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001664)
homerofgods (updater)
2012-12-28 14:07

If you hit the head with knife it's still headshot.. no?
(0001670)
McWise (reporter)
2012-12-29 19:01

If you don't switch or you switch to any other weapon than Ruger or Barret the sound will not play, so clearly this is not intended behaviour.
(0001695)
skoskav (developer)
2013-01-18 22:21

The game incorrectly checked for Barrett or Ruger being equipped rather than being the weapon that fired the killing bullet. There was a similar issue with players burning to death and playing the burn.wav sfx.

- Issue History
Date Modified Username Field Change
2012-12-25 16:32 McWise New Issue
2012-12-28 14:07 homerofgods Note Added: 0001664
2012-12-29 19:01 McWise Note Added: 0001670
2013-01-18 22:21 skoskav Note Added: 0001695
2013-01-18 22:21 skoskav Status new => resolved
2013-01-18 22:21 skoskav Fixed in Version => 1.6.4
2013-01-18 22:21 skoskav Resolution open => fixed
2013-01-18 22:21 skoskav Assigned To => skoskav
2014-01-27 19:03 homerofgods Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker