MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000380SoldatGameplaypublic2013-08-10 00:292014-01-28 22:40
ReporterBistoufly 
Assigned Toskoskav 
PriorityimmediateSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.6.6b1 
Target VersionFixed in Version1.6.6 
Summary0000380: Inconsistent behavior when switching movement direction
DescriptionThere is an inconsistency in how switching movement is behaving when running on the ground.
If you're running left and try to change direction by holding the right key, you will effectively change direction.
But if you're running right and start holding the left key you will keep on going right.
Steps To Reproducehold Right-key then Left
Expected result: Your character will switch direction and walk to the left
Actual result: Your character keep walking right
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001912)
Bistoufly (updater)
2013-09-09 22:56

Reopening as it causes a lot of issues in 1.6.6. beta1

If you hold both left and right movement keys when jumping, it will act as if you only held one. This breaks many jump and backflip tricks.
(0001913)
skoskav (developer)
2013-09-10 20:37

I can't reproduce anything that's now broken from this. Any examples?
(0002128)
homerofgods (updater)
2014-01-28 19:26
edited on: 2014-01-28 22:35

1.6.6b1 Fixed inconsistency so that you'd go in the LAST direction pressed
1.6.6b2 Resolved some bugs involving backflipping
1.6.6 The movement behavior was changed so that you'd go in the FIRST direction pressed

The current resolution is the best for keeping consistency. Some climbers claim it would be best with a total revert and go back to inconsistency.

--
<MrBungle> http://i.imgur.com/fmpy32A.gif [^] => easier in 1.6.6 (used more in ctf)
<MrBungle> http://i.imgur.com/0DXOH.gif [^] => easier in 1.6.6b2 (used more in climb)

<evhO> http://imgur.com/kvsYYle [^] => easier in 1.6.6b2


- Issue History
Date Modified Username Field Change
2013-08-10 00:29 Bistoufly New Issue
2013-08-10 00:29 Bistoufly Status new => confirmed
2013-08-10 20:56 skoskav Status confirmed => resolved
2013-08-10 20:56 skoskav Resolution open => fixed
2013-08-10 20:56 skoskav Assigned To => skoskav
2013-09-09 22:56 Bistoufly Note Added: 0001912
2013-09-09 22:56 Bistoufly Status resolved => feedback
2013-09-09 22:56 Bistoufly Resolution fixed => reopened
2013-09-09 22:56 Bistoufly Priority normal => immediate
2013-09-10 20:37 skoskav Note Added: 0001913
2013-09-11 18:00 Bistoufly Product Version => 1.6.6b1
2013-09-11 21:17 skoskav Status feedback => resolved
2013-09-11 21:17 skoskav Resolution reopened => fixed
2014-01-28 19:26 homerofgods Note Added: 0002128
2014-01-28 19:26 homerofgods Status resolved => closed
2014-01-28 22:30 homerofgods Status closed => feedback
2014-01-28 22:30 homerofgods Resolution fixed => reopened
2014-01-28 22:30 homerofgods Note Edited: 0002128 View Revisions
2014-01-28 22:31 homerofgods Note Edited: 0002128 View Revisions
2014-01-28 22:32 homerofgods Note Edited: 0002128 View Revisions
2014-01-28 22:32 homerofgods Note Edited: 0002128 View Revisions
2014-01-28 22:33 homerofgods Note Edited: 0002128 View Revisions
2014-01-28 22:34 homerofgods Note Edited: 0002128 View Revisions
2014-01-28 22:35 homerofgods Note Edited: 0002128 View Revisions
2014-01-28 22:40 homerofgods Status feedback => closed
2014-01-28 22:40 homerofgods Resolution reopened => fixed
2014-01-28 22:40 homerofgods Fixed in Version => 1.6.6


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker