MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000542SoldatGameplaypublic2014-03-17 16:462015-10-23 19:27
ReporterNawl 
Assigned ToShoozza 
PriorityurgentSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version1.6.9b1 
Target VersionFixed in Version 
Summary0000542: Invisible shield
DescriptionYou can't throw knives through a dead body, more specifically through a place where someone died. So if someone died in the air and his body fell to the ground you can throw knives through his dead body but not through the place where he died (its like an invisible shield).
This bug ruins Dodgeball mode and probably other modes where survival is on and dead ppl are everywhere ;x
This is important for me and for all dodgeball ppl so i even made i vid where you can see the bug.
here you go:
http://www.youtube.com/watch?v=nP1eQqLHxjk [^]
TagsNo tags attached.
Attached Files? file icon 2014-04-02_17-08-56_db_liga.sdm [^] (208,832 bytes) 2014-04-02 17:51
? file icon db_liga.pms [^] (27,406 bytes) 2014-04-02 17:53

- Relationships
has duplicate 0000390resolvedExHunter Knife blocking against dead body 

-  Notes
(0002178)
homerofgods (updater)
2014-04-02 16:47
edited on: 2014-04-02 17:53

Confirmed (1.6.6) and it's apparently a well known dodgeball bug.

The dead body creates some sort of collider. After the round has ended and the dead player has respawned, the collider/invisible shield isn't there anymore.

Huge bug for dodgeball players
*Uploaded 1.6.6 demo 2014-04-02_17-08-56_db_liga
*Uploaded map for demo db_liga

(0002279)
Bistoufly (updater)
2014-08-31 02:02

Confirmed here as well. 1.6.7.
(0002284)
ExHunter (developer)
2014-09-06 23:38

Please check if it will be fixed in the upcoming 1.6.8 beta.
(0002376)
ExHunter (developer)
2014-12-31 00:36

Cannot reproduce it on my dev client for 1.6.9. Please check it in beta tho, but so long: marked as resolved.
(0002475)
homerofgods (updater)
2015-06-28 15:27

Reopen because:
Realistic players like the new change because the knife realistically stops in the dead body.
However, Dodgeball players don't like the change so much because a dead body would block knifethrows and be in the way until round ends.

I suggest a solution that would be good for both Realistic and dodgeball players. That the dead body will disappear after a short while, just like weapons do. I don't think it's necessary for the dead body to blink before disappearing, but it could be a cool effect.
(0002487)
Shoozza (administrator)
2015-09-15 18:43

I need more input from DB players. It might not be enough to make dead bodies disappear after some time as people are used to throw knives though flying dead bodies as well.
(0002488)
homerofgods (updater)
2015-09-16 13:55
edited on: 2015-09-16 13:57

Related discussion: http://forums.soldat.pl/index.php?topic=43951.msg523983#msg523983 [^]

What if it was possible to script a solution where knife can be thrown through bodies? So that normal gameplay would not be affected

(0002489)
Shoozza (administrator)
2015-09-21 14:26

Adding scripting support would make it a feature request.

I'm currently considering to make knifes only collide with dead bodies in realistic.
(0002492)
Shoozza (administrator)
2015-10-23 19:27

It will stay like it was in 1.6.9b1 for realistic, knives will pass though in non realistic.

- Issue History
Date Modified Username Field Change
2014-03-17 16:46 Nawl New Issue
2014-04-02 16:47 homerofgods Note Added: 0002178
2014-04-02 16:47 homerofgods Status new => feedback
2014-04-02 16:50 homerofgods Note Edited: 0002178 View Revisions
2014-04-02 16:50 homerofgods Note Edited: 0002178 View Revisions
2014-04-02 17:17 homerofgods Note Edited: 0002178 View Revisions
2014-04-02 17:18 homerofgods Note Edited: 0002178 View Revisions
2014-04-02 17:18 homerofgods Status feedback => confirmed
2014-04-02 17:19 homerofgods Note Edited: 0002178 View Revisions
2014-04-02 17:20 homerofgods Relationship added has duplicate 0000390
2014-04-02 17:47 homerofgods Note Edited: 0002178 View Revisions
2014-04-02 17:51 homerofgods File Added: 2014-04-02_17-08-56_db_liga.sdm
2014-04-02 17:51 homerofgods Note Edited: 0002178 View Revisions
2014-04-02 17:52 homerofgods Note Edited: 0002178 View Revisions
2014-04-02 17:53 homerofgods Note Edited: 0002178 View Revisions
2014-04-02 17:53 homerofgods File Added: db_liga.pms
2014-08-31 02:02 Bistoufly Note Added: 0002279
2014-09-06 23:38 ExHunter Note Added: 0002284
2014-09-06 23:38 ExHunter Assigned To => ExHunter
2014-09-06 23:38 ExHunter Status confirmed => feedback
2014-12-31 00:36 ExHunter Note Added: 0002376
2014-12-31 00:36 ExHunter Status feedback => resolved
2014-12-31 00:36 ExHunter Resolution open => fixed
2015-06-28 15:27 homerofgods Note Added: 0002475
2015-06-28 15:27 homerofgods Status resolved => feedback
2015-06-28 15:27 homerofgods Resolution fixed => reopened
2015-06-28 15:27 homerofgods Product Version 1.6.7b1 => 1.6.9b1
2015-06-28 15:28 homerofgods Summary invisible shield => Invisible shield
2015-06-28 15:31 homerofgods Description Updated View Revisions
2015-06-28 15:32 homerofgods Description Updated View Revisions
2015-06-28 15:33 homerofgods Status feedback => acknowledged
2015-06-28 15:33 homerofgods Description Updated View Revisions
2015-09-15 18:43 Shoozza Note Added: 0002487
2015-09-16 13:55 homerofgods Note Added: 0002488
2015-09-16 13:57 homerofgods Note Edited: 0002488 View Revisions
2015-09-21 14:26 Shoozza Note Added: 0002489
2015-10-23 19:27 Shoozza Note Added: 0002492
2015-10-23 19:27 Shoozza Status acknowledged => resolved
2015-10-23 19:27 Shoozza Resolution reopened => fixed
2015-10-23 19:27 Shoozza Assigned To ExHunter => Shoozza


Copyright © 2000 - 2022 MantisBT Team
Powered by Mantis Bugtracker