MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000651Soldat Dedicated ServerScripting Corepublic2016-04-03 08:592020-08-27 11:23
Reporterkicikici 
Assigned ToFliesLikeABrick 
PriorityhighSeveritymajorReproducibilityalways
StatusnewResolutionreopened 
Platform25OSdataOS Versiondata
Product Version2.8.0 
Target Version2.9.0Fixed in Version2.9.0 
Summary0000651: 12
DescriptionHappens always when someone joins game during map change. All scripts are SC3. Example log below.
Steps To Reproducedata
Additional Information25
TagsNo tags attached.
John
Attached Filesrar file icon scripts.rar [^] (14,460 bytes) 2016-04-03 20:27

- Relationships

-  Notes
(0002544)
Falcon (administrator)
2016-04-03 19:22

Can i have some script or snippet that can reproduce this please?
(0002545)
kicikici (reporter)
2016-04-03 20:32

I was able to reproduce this bug each time (3 tries) after scoring attached map (maybe scoring is a true reason of this bug?). Example script is also attached.

(20:21:50) kicikici scores for Alpha Team
(20:21:50) kicikici captured the Blue Flag
(20:21:50) [*] [tele] Unhandled exception occured:
(20:21:50) [*] [tele] ID must be from 1 to 32
(20:21:50) ** Detected possible Mass-Flag cheating from kicikici
(20:21:50) kicikici is admin and cannot be kicked.
(0002546)
Falcon (administrator)
2016-04-03 21:45

Sorry, unable to reproduce. Please verify the conditions required to trigger this.
(0002548)
kicikici (reporter)
2016-04-09 13:35

1. Download server from http://static.soldat.pl/downloads/soldatserver2.8.0.9_1.7.0.zip [^]
2. Unpack zip file.
3. Modify Sandboxed=0 in server.ini
4. Upload script and map to right folders.
5. Modify mapslist file (replace ctf_Ash by ctf___Z_Spiral).
6. Start server.
7. Capture the flag
8. http://imgur.com/R7Nq5YP [^]
(0002550)
Falcon (administrator)
2016-04-18 04:03

After around an hour of absolutely pointless climbing only because I've told myself I need to do this without any cheats/map modifications I found it.
It was TPlayer.OnVoteKickStart crashing due to the fact that server started it and sent starting player Id of 255, which is obviously not in range of 1..32.

- Issue History
Date Modified Username Field Change
2016-04-03 08:59 kicikici New Issue
2016-04-03 19:22 Falcon Note Added: 0002544
2016-04-03 19:22 Falcon Assigned To => Falcon
2016-04-03 19:22 Falcon Status new => feedback
2016-04-03 20:27 kicikici File Added: scripts.rar
2016-04-03 20:32 kicikici Note Added: 0002545
2016-04-03 20:32 kicikici Status feedback => assigned
2016-04-03 21:45 Falcon Note Added: 0002546
2016-04-03 21:45 Falcon Status assigned => feedback
2016-04-09 13:35 kicikici Note Added: 0002548
2016-04-09 13:35 kicikici Status feedback => assigned
2016-04-18 04:03 Falcon Note Added: 0002550
2016-04-18 04:03 Falcon Status assigned => resolved
2016-04-18 04:03 Falcon Resolution open => fixed
2020-08-27 11:16 MM Issue cloned: 0000683
2020-08-27 11:16 MM Issue cloned: 0000684
2020-08-27 11:18 MM Assigned To Falcon => FliesLikeABrick
2020-08-27 11:18 MM OS => data
2020-08-27 11:18 MM OS Version => data
2020-08-27 11:18 MM Platform => 25
2020-08-27 11:18 MM Fixed in Version => 2.9.0
2020-08-27 11:18 MM Target Version => 2.9.0
2020-08-27 11:18 MM Description Updated View Revisions
2020-08-27 11:18 MM Steps to Reproduce Updated View Revisions
2020-08-27 11:18 MM Additional Information Updated View Revisions
2020-08-27 11:19 MM Summary SC3 OnJoinGame bug during map change => 12
2020-08-27 11:19 MM Additional Information Updated View Revisions
2020-08-27 11:21 MM Status resolved => closed
2020-08-27 11:21 MM Status closed => feedback
2020-08-27 11:21 MM Resolution fixed => reopened
2020-08-27 11:23 MM Status feedback => new


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker