MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000076SoldatGraphicspublic2011-10-01 16:452014-01-09 17:40
ReporterTheOne 
Assigned ToFryer 
PriorityurgentSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.6.0 
Target VersionFixed in Version1.6.1 
Summary0000076: Flames and Statgun bullet type
DescriptionScriptcreated flames and statgun bullets are invisible, flames only appear at the nearest player. Appeared in all versions since 1.5.
Steps To ReproduceUse this code for testing:

function OnPlayerCommand(ID: Byte; Text: string): boolean;
var X, Y: Single;
    Owner: Byte;
begin
    if Text = '/flame' then
    begin
        GetPlayerXY(ID, X, Y);
        Owner := ID;
        CreateBullet(X-5,Y-35,0,0,0,5,owner);
        CreateBullet(X-5,Y-18,0,0,0,5,owner);
        CreateBullet(X-5,Y-1,0,0,0,5,owner);
        CreateBullet(X-5,Y+16,0,0,0,5,owner);
        CreateBullet(X-5,Y+33,0,0,0,5,owner);
        CreateBullet(X-5,Y+50,0,0,0,5,owner);
        CreateBullet(X-5,Y+67,0,0,0,5,owner);
        CreateBullet(X+5,Y-34,0,0,0,5,owner);
        CreateBullet(X+5,Y-17,0,0,0,5,owner);
        CreateBullet(X+5,Y,0,0,0,5,owner);
        CreateBullet(X+5,Y+17,0,0,0,5,owner);
        CreateBullet(X+5,Y+34,0,0,0,5,owner);
        CreateBullet(X+5,Y+51,0,0,0,5,owner);
        CreateBullet(X+5,Y+68,0,0,0,5,owner);
        //Horizontal line
        CreateBullet(X+34,Y-3,0,0,0,5,owner);
        CreateBullet(X+17,Y-3,0,0,0,5,owner);
        CreateBullet(X-34,Y-3,0,0,0,5,owner);
        CreateBullet(X-17,Y-3,0,0,0,5,owner);
        CreateBullet(X+34,Y+7,0,0,0,5,owner);
        CreateBullet(X+17,Y+7,0,0,0,5,owner);
        CreateBullet(X-34,Y+7,0,0,0,5,owner);
        CreateBullet(X-17,Y+7,0,0,0,5,owner);
    end
    else if Text = '/statgun' then
    begin
        GetPlayerXY(ID, X, Y);
        Owner := ID;
        CreateBullet(X - 30, Y - 30, -10, -10, 0, 14, ID);
        CreateBullet(X + 30, Y - 30, 10, -10, 0, 14, ID);
        CreateBullet(X - 30, Y + 30, -10, 10, 0, 14, ID);
        CreateBullet(X + 30, Y + 30, 10, 10, 0, 14, ID);
    end;
end;
Additional InformationVery urgent for scripted servers.
TagsNo tags attached.
Attached Files

- Relationships
duplicate of 0000018resolvedFryer Soldat Dedicated Server Bullets created by CreateBullet() are invisible 

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2011-10-01 16:45 TheOne New Issue
2011-10-01 19:40 Fryer Relationship added duplicate of 0000018
2011-10-01 19:40 Fryer Status new => resolved
2011-10-01 19:40 Fryer Fixed in Version => 1.6.1
2011-10-01 19:40 Fryer Resolution open => fixed
2011-10-01 19:40 Fryer Assigned To => Fryer
2014-01-09 17:40 homerofgods Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker