MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000092SoldatGraphicspublic2011-10-11 15:192014-01-23 01:16
ReporterBendarr 
Assigned ToShoozza 
PriorityimmediateSeveritymajorReproducibilityrandom
StatusclosedResolutionfixed 
Platformx86OSWindowsOS VersionXP SP3
Product Version1.6.1 
Target VersionFixed in Version1.6.3 
Summary0000092: Flag is stretchy or jumps/moves in slow-motion (RANDOM)
Description - Sometimes it happens, sometimes it doesn't. Only in 1.6.1

Others have said the same thing.

 - Has happened in the [Pure] CTF! server and Leo's realistic CTF server.

 - IT SEEEEMS that it only happens with YOUR team flag, when an enemy captures
   it, and then the flag becomes a part of that player even after they lose it.

 - Possibly the result of the attempted fix at the stretchy flag glitch?
Steps To ReproduceJust join and play for awhile on both teams in the 2 servers I suggested.
TagsNo tags attached.
Attached Files? file icon screenshot-11-10-11-01.bmp [^] (921,656 bytes) 2011-10-11 15:19
? file icon screenshot-11-10-11-07.bmp [^] (921,656 bytes) 2011-10-11 16:05
? file icon screenshot-11-10-11-08.bmp [^] (921,656 bytes) 2011-10-11 16:06
? file icon screenshot-11-10-11-09.bmp [^] (921,656 bytes) 2011-10-11 16:07
? file icon screenshot-11-10-11-10.bmp [^] (921,656 bytes) 2011-10-11 16:08
jpg file icon screenshot-12-02-22-02.jpg [^] (386,593 bytes) 2012-02-23 10:13

- Relationships

-  Notes
(0001213)
Bendarr (reporter)
2011-10-11 16:10

further testing showed that it is in fact both flags... and while following/specatating the flag carrier it kept my vision on the flag rather than the player while it was stretching?

Very confusing.
(0001229)
Bendarr (reporter)
2011-10-13 15:43

bump? this issue is pretty major lol
(0001230)
Furai (administrator)
2011-10-14 15:24

I can confirm that this bug exist.
(0001239)
Furai (administrator)
2011-10-15 02:19

So, I have really no idea how to reproduce it but I think that it's some client-server syncing issue. Today I caught the flag and it was like I was holding it's pole while rest was still attached to the flag spawn. So that cloth part of flag was stretched from position of my gostek to enemy flag spawn. I still was able to capture flag. Maybe client thinks that he didn't pick up flag while server says he did? Or maybe flag is made of 2 entities and somehow only one has attached to player while grabbing it while 2nd one stood in place? I'll try something to reproduce it.
(0001241)
Bonecrusher (reporter)
2011-10-15 10:54

I've experienced this bug too, however it occured only at the time I joined the server. Couldnt spot it further in the game
(0001242)
Furai (administrator)
2011-10-16 04:53

Ok, bug confirmed. It appears that at some servers every flag grab after map gets changed causes this bug.
(0001253)
Damian (reporter)
2011-11-05 21:57

I also see this bug very often. Mostly on i|Snipe and Slice.
(0001278)
Shoozza (administrator)
2011-12-21 10:32

Does this still happen in 1.6.2?
Anyone can give me an easy way to reproduce this bug?
(0001284)
Bendarr (reporter)
2011-12-21 14:52

At the time I made this, it was after 1.6 updated to 1.6.1... The problem wasn't in 1.6 but came about in 1.6.1

It remains in 1.6.2 and is a serious issue, it happens 99% of the time EVERY game.

It seems to happen when you first join the server, and the flags will be weird and stretchy and move in frozen animations like youll see a frozen flag above you, then once it (server-sided) reaches the ground or something youll see another frozen animation of it pop up 10 feet away after a second or two.

The glitch fixes itself on the first flag capture of a game. (the flags reset or something)
(0001285)
Bendarr (reporter)
2011-12-21 14:53

It also really fucks me over in gathers because while holding a frozen flag and trying to play it fucks me up because i cant see my own gostek or anything.
(0001326)
Bonecrusher (reporter)
2012-02-16 15:27

I've tested this bug with shoozza and we came to a conclusion that:
1) it only happens before the 1st cap
2) it wont happen when someone from the team run through the flag[touch it]
(0001332)
asdf (reporter)
2012-02-20 17:06

I saw this only few times and only when joining to game, being still as spectator and someone had flag - it was stretched from spawnpoint flag to the runner. In game I didn't see anytime.
But I saw something else. If flag is getting back to base automatically (after 2 or 3 minutes, I don't remember), it becomes invisible. It's still in base (I noticed that because enemy took it) and then it became visible again. It happened to me, as I remember, 2 times. This is really strange.
(0001349)
asdf (reporter)
2012-02-23 10:14

And shit happened while playing on PKS RS CS No Lagz server. SS added.
(0001372)
Shoozza (administrator)
2012-02-29 00:14

Probably fixed in next version (doesn't happen for some reason)

- Issue History
Date Modified Username Field Change
2011-10-11 15:19 Bendarr New Issue
2011-10-11 15:19 Bendarr File Added: screenshot-11-10-11-01.bmp
2011-10-11 16:05 Bendarr File Added: screenshot-11-10-11-07.bmp
2011-10-11 16:06 Bendarr File Added: screenshot-11-10-11-08.bmp
2011-10-11 16:07 Bendarr File Added: screenshot-11-10-11-09.bmp
2011-10-11 16:08 Bendarr File Added: screenshot-11-10-11-10.bmp
2011-10-11 16:10 Bendarr Note Added: 0001213
2011-10-13 15:43 Bendarr Note Added: 0001229
2011-10-14 15:24 Furai Note Added: 0001230
2011-10-15 02:19 Furai Note Added: 0001239
2011-10-15 10:54 Bonecrusher Note Added: 0001241
2011-10-16 04:53 Furai Note Added: 0001242
2011-11-05 21:57 Damian Note Added: 0001253
2011-12-21 10:32 Shoozza Note Added: 0001278
2011-12-21 10:32 Shoozza Status new => feedback
2011-12-21 14:52 Bendarr Note Added: 0001284
2011-12-21 14:52 Bendarr Status feedback => new
2011-12-21 14:53 Bendarr Note Added: 0001285
2011-12-27 14:58 Shoozza Status new => confirmed
2012-02-16 15:27 Bonecrusher Note Added: 0001326
2012-02-20 17:06 asdf Note Added: 0001332
2012-02-23 10:13 asdf File Added: screenshot-12-02-22-02.jpg
2012-02-23 10:14 asdf Note Added: 0001349
2012-02-29 00:14 Shoozza Note Added: 0001372
2012-02-29 00:14 Shoozza Status confirmed => resolved
2012-02-29 00:14 Shoozza Fixed in Version => 1.6.3
2012-02-29 00:14 Shoozza Resolution open => fixed
2012-02-29 00:14 Shoozza Assigned To => Shoozza
2014-01-23 01:16 homerofgods Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker