MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000132SoldatGameplaypublic2011-11-09 01:182013-11-30 22:37
ReporterMcWise 
Assigned Toskoskav 
PrioritynormalSeverityminorReproducibilityN/A
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version1.6.2 
Target VersionFixed in Version1.6.7 
Summary0000132: Throwing of flag is not intuitive and sometimes wrond
DescriptionIf you throw the flag and don't wait long enough *after* the throw, and turn around instantly, flag will fly a random way. Same with shooting/knifing/nading flag.
Steps To ReproduceThrow a flag and look around shortly after you threw.
Additional InformationYou could take the angle and the duration of the throw button pressed into account how the flag should fly.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001336)
asdf (reporter)
2012-02-20 17:41

Thats why I don't throw flag cause for me its around 50% chance that I'll throw where I want to.
(0001656)
skoskav (developer)
2012-12-23 01:53

I think I fixed it for the most part. It's still seems possible though if you find a weird spot where you can continuously throw it in the ground and grab it. But that shouldn't affect a regular game.
(0001657)
skoskav (developer)
2012-12-23 15:27

Re-opening because my fix only solved power flag throwing, which is only a part of the unintuitive behavior.
(0001660)
McWise (reporter)
2012-12-25 16:29

Also player's current momentum seems to have a wierd effect on flag movement
(0002022)
skoskav (developer)
2013-11-30 22:37

Fixed flag was thrown in a direction that was at least 16 milliseconds old

- Issue History
Date Modified Username Field Change
2011-11-09 01:18 McWise New Issue
2011-12-21 10:11 Shoozza Status new => acknowledged
2012-02-20 17:41 asdf Note Added: 0001336
2012-12-23 01:53 skoskav Note Added: 0001656
2012-12-23 01:53 skoskav Status acknowledged => resolved
2012-12-23 01:53 skoskav Fixed in Version => 1.6.4
2012-12-23 01:53 skoskav Resolution open => fixed
2012-12-23 01:53 skoskav Assigned To => skoskav
2012-12-23 15:27 skoskav Assigned To skoskav =>
2012-12-23 15:27 skoskav Note Added: 0001657
2012-12-23 15:27 skoskav Status resolved => feedback
2012-12-23 15:27 skoskav Resolution fixed => reopened
2012-12-23 15:27 skoskav Assigned To => skoskav
2012-12-23 15:27 skoskav Status feedback => confirmed
2012-12-25 16:29 McWise Note Added: 0001660
2013-11-30 22:37 skoskav Note Added: 0002022
2013-11-30 22:37 skoskav Status confirmed => resolved
2013-11-30 22:37 skoskav Fixed in Version 1.6.4 => 1.6.7
2013-11-30 22:37 skoskav Resolution reopened => fixed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker