MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000198SoldatGUIpublic2012-05-11 17:432016-06-15 20:15
Reporterfujifabric 
Assigned ToFalcon 
PrioritynormalSeverityminorReproducibilityalways
StatusfeedbackResolutionreopened 
Platformx64OSWindowsOS Version7
Product Version1.6.3 
Target VersionFixed in Version1.6.4 
Summary0000198: Soldat fails to display interface images when starting the game with a mod
DescriptionIt seems that when you start Soldat with a mod, the game tries to load all of the interface files (such as cursor, arrow, etc) that are located in the 'mods' folder, but normally when some of those files are missing in the folder it would use the ones in the main Interface-gfx folder and combine both (usually preferring the ones in the Interface-gfx folder over the ones in the mod folder when the files are similar -- for some reason) and in this version it appears to not combine, but just load the files from the mod folder exclusively even if there are files missing from it, and since many mod makers wanted to use some of the default files for their mods, they just didn't add such files in the mod folder but instead let Soldat load them from default -- which this time doesn't.
Steps To ReproduceCreate a folder in the mods folder with any name and leave the rest empty, (or also inside that mod folder create one called interface-gfx and leave it empty or just with random interface files). If it's empty it will only load the guns and text from the interface, but the cursor, arrow, menucursor, health, ammo, jets and the rest won't load... if you put files in the mod folder like menucursor then it will load that one image but not the rest.

note: select the mod and start Soldat from the mod starter to see the issue.
Additional InformationOn the plus side it's good that now it loads interface files from the mod, because in the past it would ignore them and use the ones in the main interface folder instead, but the problem is when there are files missing from the mod folder because then Soldat won't show them at all (instead of using the ones in the main interface-gfx folder).
TagsNo tags attached.
Attached Filesjpg file icon i_bug.jpg [^] (172,431 bytes) 2012-05-11 17:43

- Relationships
related to 0000207confirmed Needs gostek-gfx customization for team 0, 3 and 4 
related to 0000614resolvedShoozza setup.SIF must be in a custom interface 
related to 0000294confirmed Using a scenery folder in a mod fails to overwrite sceneries ingame 
related to 0000565new Background on interfaces is not always detected 
related to 0000612new Soldat prioritizing interface-gfx over custom-interfaces folder 

-  Notes
(0001482)
Shoozza (administrator)
2012-05-12 15:58

Rewrote the part of the interface loading code.
(0002120)
homerofgods (updater)
2014-01-23 01:39

Reopening because everything is still not how it should be. Maybe I'll get time to test it all but some help would be appriciated. I just noticed alot of buggyness when I tried to make a little interface mod.

- Issue History
Date Modified Username Field Change
2012-05-11 17:43 fujifabric New Issue
2012-05-11 17:43 fujifabric File Added: i_bug.jpg
2012-05-11 18:24 Shoozza Status new => confirmed
2012-05-12 15:58 Shoozza Note Added: 0001482
2012-05-12 15:58 Shoozza Status confirmed => resolved
2012-05-12 15:58 Shoozza Fixed in Version => 1.6.4
2012-05-12 15:58 Shoozza Resolution open => fixed
2012-05-12 15:58 Shoozza Assigned To => Shoozza
2014-01-23 01:39 homerofgods Note Added: 0002120
2014-01-23 01:39 homerofgods Status resolved => feedback
2014-01-23 01:39 homerofgods Resolution fixed => reopened
2015-04-15 17:50 homerofgods Relationship added related to 0000207
2015-04-15 17:50 homerofgods Relationship deleted related to 0000207
2015-04-17 14:52 homerofgods Relationship added related to 0000294
2015-04-17 14:52 homerofgods Relationship added related to 0000207
2015-04-17 21:39 homerofgods Relationship added related to 0000571
2015-04-17 21:39 homerofgods Relationship deleted related to 0000571
2015-04-18 22:23 homerofgods Relationship added related to 0000565
2015-05-29 18:22 homerofgods Relationship added related to 0000286
2015-05-29 18:22 homerofgods Relationship deleted related to 0000286
2015-05-29 18:24 homerofgods Relationship added related to 0000612
2015-05-29 18:24 homerofgods Relationship added related to 0000614
2016-06-15 20:15 Shoozza Assigned To Shoozza => Falcon


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker