MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000286SoldatOtherpublic2012-12-25 20:382015-09-14 21:45
Reporterhomerofgods 
Assigned ToShoozza 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version1.6.9b1 
Target VersionFixed in Version1.6.9 
Summary0000286: won't respawn in survival
DescriptionWhen you play survival and the bot kills himself on the first kill, you won't respawn


(Also true for normal players, not only bots)
Steps To ReproduceChoose Airpirates realistic and lure the bot down to his death without killing him.
Additional Informationattatched demo

It happens regardless of kill limit
TagsNo tags attached.
Attached Files? file icon demo23.sdm [^] (117,886 bytes) 2012-12-25 20:38

- Relationships
duplicate of 0000598feedbackExHunter Players respawning mid-round in Survival. 

-  Notes
(0001667)
homerofgods (updater)
2012-12-28 21:16
edited on: 2013-08-03 01:48

I did some more research and maybe found the root of the problem.
If you kill yourself by going outside of map in survival mode, you will respawn!

So, what happens in that demo is that I get auto-killed because I win the round, but the bot respawns after that because he went outside of map. Now he will live forever since it's fucked up.

(0001818)
homerofgods (updater)
2013-08-03 01:53

Happens all the time in survival. Try to play Airplanes with a few bots and see what happens.

If one bot suicides by going out of map he will spawn after the other players are dead, and live forever since round won't end.
(0002373)
ExHunter (developer)
2014-12-11 22:10

Tested as much as possible I could alone. Please consider serious tests and feedback concerning survival game mode in the next beta. Tried to fix as much as possible, but I cannot tell if now everything is fine.

Please feedback in the next beta if it works now! Thanks!
(0002469)
homerofgods (updater)
2015-05-20 20:47
edited on: 2015-05-20 21:00

Reopened because it's not completely fixed yet.

I apologize because I wrote 'realistic' in the ticket, I ment Survival. I corrected it.

ExHunter I don't think you understand what exactly this ticket is about, I will try to explain:

-Fixed survival mode dead body outside map respawn bug <-- This is fixed

-Fixed survival mode respawning if out of map after round end results in a never ending round <--This is fixed, but there is still a problem if a player dies outside of map and the players body/ghostek does not have enough time to fall all the way down.

------- Here is what happens in 1.6.9b1 -------

1. Start a SURVIVAL DM with lots of bots
2. Play on Airpirates
3. Some of the bots will possibly fall down and die by suicide at the bottom of Airpirates.

Now.. depending on if the players/bots ghostek reach the very bottom of the map, there might or might not still be a problem.

-If the ghostek has time to reach the bottom the map, the player/bot will respawn as normal and everyone is happy.

-But if the ghostek does not have time to fall all the way down, the players/bots will respawn one at a time after round end. They will get auto-killed right after their spawn protection ends, but they should not respawn after round end in the first place.

(0002486)
Shoozza (administrator)
2015-09-14 21:45

Players will not respawn when falling outside of the map after round has ended.
Because if they do they will be the only once alive requiring the server to kill them.
This way the bug is avoided.

- Issue History
Date Modified Username Field Change
2012-12-25 20:38 homerofgods New Issue
2012-12-25 20:38 homerofgods File Added: demo23.sdm
2012-12-28 21:16 homerofgods Note Added: 0001667
2012-12-28 21:31 homerofgods Note Edited: 0001667 View Revisions
2013-06-25 13:52 Falcon Status new => acknowledged
2013-08-03 01:48 homerofgods Note Edited: 0001667 View Revisions
2013-08-03 01:53 homerofgods Note Added: 0001818
2013-12-04 01:08 homerofgods Severity minor => major
2014-11-06 08:09 homerofgods Relationship added related to 0000598
2014-12-11 22:10 ExHunter Note Added: 0002373
2014-12-11 22:10 ExHunter Assigned To => ExHunter
2014-12-11 22:10 ExHunter Status acknowledged => feedback
2015-04-18 23:02 homerofgods Relationship deleted related to 0000598
2015-04-18 23:02 homerofgods Relationship added duplicate of 0000598
2015-04-18 23:03 homerofgods Status feedback => closed
2015-04-18 23:03 homerofgods Resolution open => duplicate
2015-05-20 20:47 homerofgods Note Added: 0002469
2015-05-20 20:47 homerofgods Status closed => feedback
2015-05-20 20:47 homerofgods Resolution duplicate => reopened
2015-05-20 20:48 homerofgods Summary won't respawn in realistic => won't respawn in survival
2015-05-20 20:48 homerofgods Description Updated View Revisions
2015-05-20 20:50 homerofgods Note Edited: 0002469 View Revisions
2015-05-20 20:50 homerofgods Note Edited: 0002469 View Revisions
2015-05-20 20:50 homerofgods Note Edited: 0002469 View Revisions
2015-05-20 20:59 homerofgods Note Edited: 0002469 View Revisions
2015-05-20 21:00 homerofgods Note Edited: 0002469 View Revisions
2015-05-20 21:08 homerofgods Status feedback => acknowledged
2015-05-29 18:22 homerofgods Relationship added related to 0000198
2015-05-29 18:22 homerofgods Relationship deleted related to 0000198
2015-06-20 17:23 homerofgods Product Version 1.6.3 => 1.6.9b1
2015-09-14 20:46 Shoozza Status acknowledged => confirmed
2015-09-14 21:45 Shoozza Note Added: 0002486
2015-09-14 21:45 Shoozza Status confirmed => resolved
2015-09-14 21:45 Shoozza Fixed in Version => 1.6.9
2015-09-14 21:45 Shoozza Resolution reopened => fixed
2015-09-14 21:45 Shoozza Assigned To ExHunter => Shoozza


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker