MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000072SoldatGameplaypublic2011-09-29 13:192013-12-15 10:04
ReporterBonecrusher 
Assigned ToShoozza 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
Platformx86OSWindowsOS VersionXP SP3
Product Version1.6.0 
Target VersionFixed in Version1.6.3 
Summary0000072: Alt + R sometimes triggers a weapon reload
DescriptionI have my 'Return the Flag' taunt set on R and sometimes when I use it the weapon I am carrying is being reloaded damn.
Steps To ReproduceGet a weapon
make sure it's possible to reload[less than max bullet capacity lol]
press alt+r
TagsNo tags attached.
Attached Files? file icon bug.sdm [^] (15,269 bytes) 2011-10-01 17:04

- Relationships
related to 0000149closedShoozza Spas reloads itself even when player doesn't click "reload" button 

-  Notes
(0001181)
Shoozza (administrator)
2011-09-29 19:03

Could it be that it's reloading because you release the alt key after the r key?
(0001182)
Bonecrusher (reporter)
2011-09-29 19:08

No, it occurs at the moment i press r. Alt then R
(0001183)
Shoozza (administrator)
2011-09-29 23:22

Are you sure it happens when the keys are pressed down and not after you released one of them?

Normally taunt keys aren't hold forever...

I believe this happens because you release the alt key earlier then the r key which triggers the reload because Soldat thinks r was pressed alone.

Could that be the reason?
(0001191)
Bonecrusher (reporter)
2011-10-01 17:04
edited on: 2011-10-01 17:04

Key combo how i press it:
alt, then while still holding
R, holding
and it reloads without releasing the R key

I recorded and uploaded a demo of this happening bug.sdm

(0001237)
asdf (reporter)
2011-10-14 22:08

I had sometimes similar bug, but with F key - when I'm using this taunt ("You think that's funny?!"), sometimes gostek drop his weapon.
(0001327)
Bonecrusher (reporter)
2012-02-16 16:21

only happens when using right alt button
(0001328)
Shoozza (administrator)
2012-02-16 17:34

happens always when you use right alt+r
(0002086)
homerofgods (updater)
2013-12-15 10:04

Closing ticket because right alt + R does not trigger reload anymore, fixed.

- Issue History
Date Modified Username Field Change
2011-09-29 13:19 Bonecrusher New Issue
2011-09-29 19:03 Shoozza Note Added: 0001181
2011-09-29 19:03 Shoozza Assigned To => Shoozza
2011-09-29 19:03 Shoozza Status new => feedback
2011-09-29 19:08 Bonecrusher Note Added: 0001182
2011-09-29 19:08 Bonecrusher Status feedback => assigned
2011-09-29 23:22 Shoozza Note Added: 0001183
2011-09-29 23:22 Shoozza Status assigned => feedback
2011-10-01 17:04 Bonecrusher Note Added: 0001191
2011-10-01 17:04 Bonecrusher Status feedback => assigned
2011-10-01 17:04 Bonecrusher File Added: bug.sdm
2011-10-01 17:04 Bonecrusher Note Edited: 0001191 View Revisions
2011-10-11 00:23 Shoozza Note Added: 0001209
2011-10-11 00:23 Shoozza Status assigned => new
2011-10-11 00:24 Shoozza Note Deleted: 0001209
2011-10-14 22:08 asdf Note Added: 0001237
2012-02-03 14:58 Shoozza Assigned To Shoozza =>
2012-02-03 14:59 Shoozza Relationship added related to 0000149
2012-02-16 12:21 Shoozza Status new => acknowledged
2012-02-16 16:21 Bonecrusher Note Added: 0001327
2012-02-16 17:34 Shoozza Note Added: 0001328
2012-02-16 17:34 Shoozza Status acknowledged => confirmed
2012-02-16 21:12 Shoozza Status confirmed => resolved
2012-02-16 21:12 Shoozza Fixed in Version => 1.6.3
2012-02-16 21:12 Shoozza Resolution open => fixed
2012-02-16 21:12 Shoozza Assigned To => Shoozza
2013-12-15 10:04 homerofgods Note Added: 0002086
2013-12-15 10:04 homerofgods Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker