MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000149SoldatGameplaypublic2012-01-07 18:112013-12-15 09:57
Reporterasdf 
Assigned ToShoozza 
PriorityimmediateSeveritymajorReproducibilitysometimes
StatusclosedResolutionfixed 
Platformx86OSWindowsOS VersionXP SP2
Product Version1.6.2 
Target VersionFixed in Version1.6.3 
Summary0000149: Spas reloads itself even when player doesn't click "reload" button
DescriptionSometimes when shooting with shotgun it just starts reload. It's very annoying cause when fighting I don't look on gostek, but on enemy and I can't see when weapon automatically reloads and it makes you an easy target to kill. It very often happens when having 2 bullets left, sometimes more.
Steps To Reproduce1. Start game (LAN or Internet)
2. Take Spas.
3. Play as always until you recognize that you shoot on your sides.
TagsNo tags attached.
Attached Files? file icon demo4.sdm [^] (215,248 bytes) 2012-02-20 16:56

- Relationships
related to 0000072closedShoozza Alt + R sometimes triggers a weapon reload 

-  Notes
(0001300)
asdf (reporter)
2012-02-02 21:17

And...? No one comment this, no one had that? Unbelievable.
(0001302)
Shoozza (administrator)
2012-02-03 02:52

Does it happen when you play alone with bots (offline)?
Does it happen in LAN when you run the server (soldat client server)?

Does it happen with lots of players playing?

I guess it could be a corrupted packet.

A demo of that bug could really help to find that out. Can you make one?
(0001315)
asdf (reporter)
2012-02-11 22:05

1. I have to try cause I don't play Spas now due to this bug happening.
2. I don't host servers due to bad Internet and no one from my friends like and play Soldat, so I can't answer.
3. Yea, sometimes sth very strange was happening that if some1 was reloading Spas, sometimes game automatically was starting reload my weapon. If it was full, it was reloading normally, but without sound, but if magazine wasn't full, it was reloading like Spas, one bullet by one even when not holding shotgun (I had it most time with Steyr, but in 1.5, in 1.6 it happens more rarely)
4. Yeah, I can try to make a demo in future.
(0001324)
Shoozza (administrator)
2012-02-16 12:12

Waiting for demo and additional information.
(0001331)
asdf (reporter)
2012-02-20 17:01
edited on: 2012-02-21 19:14

Dunno if U will see sth - when I was watching this, nothing happened on demo, but when I was playing (with bots), Spas reloaded 4 times by itself, without pushing reload button. You can try to reproduce it, I disabled every weapons but Spas and took bot Billy to make sure that he won't spawn with fists only. I killed him and didn't reload but was waiting for that glitch and it happened.

(0001375)
Shoozza (administrator)
2012-03-01 01:10

This bug was added in 1.6.1.
Reload happens when any bot/player reloads spas.
(0002085)
homerofgods (updater)
2013-12-15 09:57

Closing ticket because I couldn't reproduce in 1.6.6. It's fixed

- Issue History
Date Modified Username Field Change
2012-01-07 18:11 asdf New Issue
2012-02-02 21:17 asdf Note Added: 0001300
2012-02-03 02:52 Shoozza Note Added: 0001302
2012-02-03 02:52 Shoozza Status new => feedback
2012-02-03 14:59 Shoozza Relationship added related to 0000072
2012-02-11 22:05 asdf Note Added: 0001315
2012-02-11 22:05 asdf Status feedback => new
2012-02-16 12:12 Shoozza Note Added: 0001324
2012-02-16 12:12 Shoozza Status new => feedback
2012-02-20 16:56 asdf File Added: demo4.sdm
2012-02-20 17:01 asdf Note Added: 0001331
2012-02-20 17:01 asdf Status feedback => new
2012-02-21 19:14 asdf Note Edited: 0001331 View Revisions
2012-03-01 00:53 Shoozza Status new => confirmed
2012-03-01 01:10 Shoozza Note Added: 0001375
2012-03-01 02:00 Shoozza Status confirmed => resolved
2012-03-01 02:00 Shoozza Fixed in Version => 1.6.3
2012-03-01 02:00 Shoozza Resolution open => fixed
2012-03-01 02:00 Shoozza Assigned To => Shoozza
2013-12-15 09:57 homerofgods Note Added: 0002085
2013-12-15 09:57 homerofgods Status resolved => closed


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker